Intersolve platform

Incident Report for Intersolve status page

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 15:39 CEST

Identified

We've identified that parts of the Intersolve platform are partially down
Posted Apr 03, 2026 - 11:06 CEST
This incident affected: Intersolve domain and application health.